Data and UI Irregularities - US and EU regions

Incident Report for New Relic

Resolved

Our teams have resolved two concurrent service interruptions affecting data ingestion and query services.

On January 12th, 2026, a subset of customers in the US and EU regions may have experienced latency or timeouts when querying data in New Relic. Teams implemented a fix, restoring affected query performance at 17:29 UTC.

Separately, a subset of customers in the US and EU regions may have experienced errors when sending data to New Relic. This interruption could have resulted in potential data drops for data sent during this timeframe, depending on client-side retry settings, and may have generated false alert notifications regarding host reporting status. This interruption appears related to a disruption with a New Relic third-party edge service provider. To remediate, our teams have shifted traffic to an alternate cloud provider and have seen recovery of impacted services.
Posted Jan 12, 2026 - 18:10 UTC

Identified

Some customers in the US and EU region may experience errors when sending data to New Relic, issues in viewing data in real time, and delayed or missing alert notifications related to real time data. We are seeing recovery from mitigating actions and will continue to provide updates until services have been restored to normal operation.
Posted Jan 12, 2026 - 17:36 UTC

Update

We have engaged our additional teams to assist with further investigation and are evaluating additional mitigation efforts.
Posted Jan 12, 2026 - 15:53 UTC

Update

We are continuing to investigate this issue.
Posted Jan 12, 2026 - 15:22 UTC

Investigating

We are currently investing an issue causing timeouts/query lag in NRDB
Posted Jan 12, 2026 - 15:21 UTC
This incident affected: Alert Notifications : Europe (APM : Europe, Browser : Europe, Infrastructure : Europe, Logs : Europe, Mobile : Europe, NRQL : Europe, Serverless : Europe, Synthetics : Europe), UI : US (Alerts : US, APM : US, Auto-Telemetry with Pixie : US, AWS Lambda Integration : US, Browser : US, Dashboards : US, Incident Intelligence : US, Infrastructure : US, Infrastructure Integrations : US, Logs : US, Lookout : US, Mobile : US, Open Instrumentation : US, Proactive Detection : US, Serverless : US, Synthetics : US), UI : Europe (Alerts : Europe, Infrastructure : Europe, Infrastructure Integrations : Europe, Logs : Europe), Alert Notifications : US (Infrastructure : US, Logs : US), Data Ingest : US (Infrastructure Agent : US, Log API : US, Metric API : US, OTLP API : US), and Data Ingest : Europe (Infrastructure Agent : Europe, Log API : Europe, Metric API : Europe, OTLP API : Europe).